开发工具 · Tool

使VSCode支持 vue 文件的基本语法高亮

•̀.̫•́✧ · 8月6日 · 2020年本文385字 · 阅读1分钟70

第一步,要支持 vue 文件的基本语法高亮

这里,我试过3个插件: vueVueHelper 和 vetur ,最终选择使用 vetur 。

使VSCode支持 vue 文件的基本语法高亮-歪?是3.1415926吗

安装插件: Ctrl + P 然后输入 ext install vetur 然后回车点安装即可。

ps: vscode 的插件安装比 PHPStorm 的插件安装更快捷方便,安装完成后还不用重启整个程序,只要重新加载下工作区窗口就可以了。

安装完 vetur 后还需要加上这样一段配置下:

"emmet.syntaxProfiles": {
  "vue-html": "html",
  "vue": "html"
}

这时可以打开一个vue文件试试,注意下右下角状态栏是否正确识别为 vue 类型:

使VSCode支持 vue 文件的基本语法高亮-歪?是3.1415926吗

如果被识别为 text 或 html ,则记得要点击切换下。

0 条回应